SOMME.SI Retour

 

Exemple 1 (débutant)

 Critère : une constante.

   

On souhaite connaître la quantité totale d'articles vendus en fonction de la catégorie de l'article. Il existe trois catégories identifiées par un code numérique : 1, 2 et 3.

Remarque (initié)
Donc, somme.si réalise l'équivalent d'une boucle avec un test interne.

   

Exemple 2 (initié)

 Critère : une expression limitée à une fonction.


Idem Exemple 1 mais paramétré en fonction du libellé (Cat1, Cat2 et Cat3). 

On utilise la fonction DROITE qui permet d'extraire x caractères à partir de la droite d'une chaîne de caractères.

   

Exemple 3 (débutant)

 Critère : une référence à une cellule.


On souhaite cumuler les kilomètres parcourus en fonction de la zone fréquentée.

Remarque (initié)
La saisie (en C13) de la zone est contrôlée via une liste déroulante(Données- Validation - Liste).

   

Exemple 4 (initié)

 Critère : une expression (ici, une concaténation).

On souhaite :

1° cumuler les kilomètres parcourus par comparaison avec une valeur donnée(stockée en E17)

2° Choisir l'opérateur de comparaison via la liste des opérateurs (Données- Validation - Liste) stockée en C18).

Remarques

1° la construction du critère se réalise grâce à une concaténation de deux cellules : autrement dit, le critère est paramétré au niveau de l'opérateur et de la valeur de référence.

2° la plage "critère" et la plage "cumul" (C4:C11) sont les mêmes puisque la comparaison porte sur les valeurs utilisées pour le cumul.



Exemple 5 (initié)

 Critère : deux conditions liées par un ET.

On souhaite :

cumuler les chiffres d'affaires d'un représentant donné, pour une ville donnée. Cette situation fait intervenir deux conditions...

Solutions avec des colonnes de travail

Une solution utilise une combinaison de Somme, de Et et de Si
L'autre solution utilise Somme.si 

Formules

1° En E3 : =B3=C$16

2° En F3 : =D3=C$17

3° En G3 : =ET(E3;F3)

4° En H3 : =SI(G3;C3;0)

5° En C18 : =SOMME(H3:H14)

La formule avec SOMME.SI :

=SOMME.SI(G3:G14;VRAI;H3:H14)

 

 

  | Formule : {=SOMME(SI(B3:B14=C16;SI(D3:D14=C17;1*(C3:C14);0);0))}

 

Solution avec une formule matricielle
Cette solution n'utilise aucune colonne supplémentaire.

Remarques

La solution 1 manipule 1 plage
La solution 2 manipule 2 plages
La solution 3 manipule 3 plages

(Le hasard de la numérotation...)