HTML VALIDATOR - upgrade to Firefox 4.0 / 5.0 / 6.0 / ... / 48.0

     Welcome     

This page is shown only the first time after an upgrade of HTML Validator for Firefox and Mozilla. Please take the time to read the user guide.

Thanks for all the persons who helped: the translators, the persons adding help in Htmlpedia, the one reporting bugs and so on.... Without you, this program would not exist !

     User Guide    
   Htmlpedia   

Htmlpedia If you are interested in improving the 'help' part of the extension, please use the new Wiki server Htmlpedia: the HTML encyclopedia that anyone can edit. For more info, read here.

 You want to help, I am looking for
  • help to improve the help of SGML error messages.
  • integrate other external validation program
  • translations
  • feedback and bug reports
     News     

!!! IMPORTANT !!!
  • The extension 0.973 contains a lot of changes to keep the extension working with Firefox 48 and Electrolysis. Due that Electrolysis is a huge architecture change with previous Firefox version. The changes in the extension are big too ! Do not hesitate to report any new problem by mailing me at mgueury@skynet.be !
  • The extension 0.965 fixes compatibility issues with Firefox 44.0
  • The extension 0.964 is the first version signed in Addons mozilla.org and that works for all platforms 
    ( Linux32+64 bits, MacOsX, Windows32+64 bits)
  • The extension 0.963 support Windows 64 bits
  • The extension 0.962 fixes an issue HTML online validator URL
  • The extension 0.958 fixes an issue with the icon not installed correctly in add-on toolbar
  • The extension 0.957 is compatible with FF 23. "Domain not in List" incompatibility issue solved (see releases notes)
  • Due to Numerous changes due to Firefox 4.0 / 5.0,
    the extension 0.9 is compatible only with Firefox 4.0 +
  • The browser icon is in the add-on bar. The status bar does not exist in FF 4.0 anymore.
  • All platforms binaries will need to be recompiled for Firefox 5.0 again... Look at the source and the forum (see sidebar) if you want to help on the migration.
  • To enable HTML 5 validation, it is possible to validate the page with W3c Online too.
     Donate     

Do you like this extension? I wrote this extension during my very limited freetime, which conflicts with my family life. If you would like to donate to encourage my continuing maintenance and improvement of the extension, you can do it using the Paypal. If you can't, I really appreciate bug fixes, bug reports, translations and improvement suggestions and requests :-) Thank you in advance.

     Sponsors     

If you want  to see your ads here. Send me a mail.

     Help     
  • First, read the FAQ
  • Check the forums
  • Add your question in it.
  • If still, no answer, do not hesitate to contact me :
    Marc Gueury mgueury@skynet.be